Compatible iOS SDK versions: 2.1+

The easiest way to install PushBots library into your iOS project using CocoaPods:

First make sure that you have CocoaPods installed. If you are having troubles with CocoaPods, check out the troubleshooting guide

gem install cocoapods

Installing cocoapods for the first time: 

  1. Create new xcode project.

2. Make sure you've created the Notification Service Extension 


3. Close the project
4. Create A file named Podfile  in your project root folder, along with .xcodeproj file

5. Paste this into Podfile  and make sure you update xcode_project_title  or Add Pushbots and PushbotsNSExtension pods to your existing Podfile: 

platform :ios, '9.0'
target 'xcode_project_title' do
  pod 'Pushbots', '>= 2.4.3'
end
target 'PushbotsNSExtension' do
  pod 'Pushbots', '>= 2.4.3'
end

6. Run these commands from terminal while xcode is closed in the directory that contains the Podfile  to install Pushbots SDK:

pod repo update
pod install

7. Open {xcode_project_title}.xcworkspace
8. If you get this warning linking against a dylib which is not safe for use in application extensions  for Notification Service Extension, you can safely ignore it.

Did this answer your question?